Product Support

Product Support
A description has not yet been added to this group.

Computer no longer detects Razer Naga mouse.

  •    I've had this Razer Naga mouse for about 5 months now and it's been working since then, up until now.  I was in the middle of a gaming session and the mouse stopped tracking movement.  Every button and key on the mouse still worked and the lights still glowed but the sensor wouldn't pick up movement until it stopped working alltogether. 

       The mouse now just sits there with the lights turning on and off while windows continually beeps at me suggesting that I am unplugging a device from my computer.  Opening up the Razer Naga's configurator shows that the mouse isn't even plugged in.  I've tried using the mouse with several computers (windows 7, vista, XP, leopard X) and neither had shown anything different from what I described.

       Replugging the mouse gives me a windows message saying that Device Drivers could not be installed successfuly.

       I've tried different computers, mouse pads, over a gazillion usb ports, and now I'm out of ideas.  Has anyone experienced anything like this with any other type of mouse?



    [edited by: Rattletrap]
  • Sounds freid to me. RMA

     

  • Try updating the firmware on razers site. If that doesnt work, its fried as gms said. (I have a razer lachaesis, impossible to open...)
  • KennyKo:
    Try updating the firmware on razers site. If that doesnt work, its fried as gms said. (I have a razer lachaesis, impossible to open...)

     

       Yep, I downloaded the latest drivers and firmware and it still won't work. :s  Guess it's time to contact razer support. >_<